Settlement Review

Incident Report for Cardstream

Resolved

Nuvei has confirmed that transactions were not affected.
Posted Jun 20, 2025 - 12:42 BST

Monitoring

Barclaycard FasterPayments transactions due to be sent for settlement 18 June have been accepted for settlement today.

Some EvoPayments transactions due to be sent for settlement 18 June have been accepted for settlement this morning.

Cardstream is in conversations with Nuvei to confirm if any transactions will receive a delay in the settlement of funds.

Please note, this may result in a day's delay in the settlement of funds for affected transactions.
Posted Jun 19, 2025 - 15:40 BST

Investigating

Cardstream is reviewing settlement processing for transactions processed on 18 June.

An update will be shared shortly following further investigations.
Posted Jun 19, 2025 - 09:44 BST
This incident affected: Cardstream Payment Gateway.