Visa 3-D Secure
Incident Report for Cardstream
Resolved
Following our monitoring period, Cardstream can confirm connections with the 3-D Secure service for Visa remain at normal levels.
Posted Sep 21, 2023 - 12:00 BST
Monitoring
Cardstream can confirm that connections with the 3-D Secure service for Visa have returned to normal.

Our engineers are continuing to monitor.
Posted Sep 21, 2023 - 09:59 BST
Investigating
Cardstream has identified connection errors with the 3-D Secure service for Visa.

Our engineers are investigating, and we will provide an update within the next hour.
Posted Sep 21, 2023 - 09:03 BST
This incident affected: Cardstream Payment Gateway.