OBN Global Limited can confirm transactions authorised on 8th April have been received and processed. OBN Global apologises for the delay to settlement.
Posted Apr 11, 2025 - 16:13 BST
Update
OBN Global Limited has been notified by the underlying supplier that the settlement instructions for transactions authorised on 8th April have now been sent. OBN Global apologises for the delay to settlement.
Posted Apr 10, 2025 - 17:27 BST
Update
OBN Global Limited has been notified by the underlying supplier that they were still unable to send settlement instructions for transactions authorised on 8th April. The result will be a knock-on two-day delay in settlement for OBN Global merchants for transactions that were authorised on the day above. Settlement for transactions authorised on 9th April and after are unaffected. OBN Global apologises for this delay.
Posted Apr 10, 2025 - 10:08 BST
Monitoring
OBN Global Limited has been notified by an underlying supplier that they were unable to send settlement instructions for transactions authorised on 8th April. The result will be a knock-on one-day delay in settlement for OBN Global merchants for transactions that were authorised on the day above. OBN Global apologises for this delay.