Delay in Settlement Processing – OBN Global Limited
Incident Report for Cardstream
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 11:20 GMT
Monitoring
At 10:20 GMT OBN Global Limited informed us that Sales transactions authorised on 28/10/2024 may be delayed for settlement by one day, and so combined with the Merchant’s next scheduled settlement.

This delay is caused by an external party that provides transaction related interchange and scheme fee details to OBN Global.
Posted Oct 29, 2024 - 11:33 GMT
This incident affected: OBN.