Delay in Settlement - Evo Payments

Incident Report for Cardstream

Resolved

Cardstream has monitored settlement processes overnight for EVO Payments and this incident is now resolved.
Posted Mar 29, 2025 - 08:48 GMT

Monitoring

Please be aware that we are continuing to monitor settlement processing.
Posted Mar 28, 2025 - 15:49 GMT

Update

Our engineers are recapturing requests for pending transactions.

We will provide a further update when these have been completed.
Posted Mar 28, 2025 - 11:33 GMT

Identified

Cardstream has identified an issue with Settlement files for transactions processed 26/03 and 27/03 for transactions processed using Evo Payments.

Our engineers are working to resolve this and further updates will be provided.
Posted Mar 28, 2025 - 10:16 GMT
This incident affected: Cardstream Payment Gateway.