Metro Bank Issued Cards – 3DS Errors

Incident Report for Cardstream

Resolved

This incident has been resolved.
Posted Oct 28, 2024 - 10:07 GMT

Investigating

Cardstream has seen an increase in 3DS errors for Cards Issued by Metro Bank.

Cardstream is in communications with Metro Bank to confirm resolution.
Posted Oct 18, 2024 - 13:49 BST
This incident affected: Cardstream Payment Gateway.